QCart Documentation

Drag and Drop

When you first open QCart, you have a blank workspace. The workspace consists of empty cells where you can put cues. Drag and drop any audio file from the Desktop or Finder into any of these cells to create a cue. As you drag the file into the workspace, you will see which hotkey trigger QCart will automatically assign to your cue.

You can rearrange the cues within the workspace at anytime by drag and drop. You can drag and drop multiple files at a time into QCart. It will fill any empty cells, filling in from left to right, and wrapping around.

When you save a file, any audio files used in the workspace are automatically saved into the document. You can easily transfer files between computers and be sure all the audio files you need will be there.

Cue

There are a few often used properties you can change directly on the cue for quick access. You can toggle the hold, loop, and solo properties, as well as exporting the underlying audio file. These properties are available by clicking the gear icon, or right-clicking the cue.

The normal playback mode for a cue is to play exactly once when you press the play button or one of the other triggers. If you trigger the same cue while it is playing, it will stop. There are three ways to adjust how a cue is played:

Hold

When hold is on, the cue will only play while the trigger is held down and will stop when the trigger is released.

Loop

When loop is on, the cue will repeat indefinitely.

Solo

Solo means that cue is played alone. All currently playing cues will be stopped when a cue with solo enabled is played.

Cue Inspector

Click any cue to select it, and it will get a blue glow. When a cue is selected, you can edit its properties in the inspector pane. In the cue inspector, you can update all the different properties of the cue. You can change its name, change the color, and customize hotkey or MIDI triggers.

Within the inspector, you can also adjust the volume of the cue, as well as the start and end times of the file with the the visual waveform editor. This allows you to quickly trim out the parts of the file you don't want to play on the fly.

On the far right side of the inspector, you can add effects to your cue using Audio Units.

Cells

All the cells that hold cues are laid out on a grid. The default is 4x4 which gives 16 possible cues. You can also change how many cells are displayed by choosing Cart > Change Grid or using the keyboard shortcut ⌘G. That will show a selection of all 6 possible layouts, which range from 2x2 to 5x5.

The grid is anchored to the top left of the window, so changing the grid size will drop off cues from the bottom and right. Any cues outside of the new grid when changing sizes will be removed when the document is saved.

Show mode

QCart has a feature called Show Mode. Show Mode transforms the workspace into a interface simplified for playback. The cue inspector is hidden, as well as any empty cells. The cues themselves are larger and the cue itself becomes a playback button that has a much larger target. Nothing is editable when the workspace is locked, so you don't have to worry about accidentally changing some property when playing your cues.

Broken Cues & Warnings Inspector

QCart will check for a couple common issues with your cues, and let you know if it finds anything. For example, if one of your cues shares a hotkey trigger with another cue, QCart will let you know, just in case.

Keyboard Shortcuts

Key Symbols

Symbol Meaning
command
shift
option
delete

Default Key Map

Command Key
Pause All [
Resume All ]
Duck/Unduck Master Volume .
Panic All escape
Hard Stop All esc esc
  • Panic fades out all playing cues over the panic duration, which is 1 second by default and which can be set in Workspace Settings (found under the View menu).
  • Hard Stop stops all playing cues immediately.

QCart Menu

Command Key
Hide QCart ⌘H
Hide Others ⌥⌘H
Quit QCart ⌘Q

File Menu

Command Key
New Workspace ⌘N
New Cart ⌘T
Open... ⌘O
Close Window ⌘W
Close Tab ⇧⌘T
Save ⌘S
Save As... ⇧⌘S

Edit Menu

Command Key
Undo ⌘Z
Redo ⇧⌘Z
Cut ⌘X
Copy ⌘C
Paste ⌘V
Delete

View Menu

Command Key
Inspector ⌘I
Workspace Settings ⌘,
Log ⌘L
Broken Cue & Warnings ⌘B
Enter Edit Mode ⇧⌘[
Enter Show Mode ⇧⌘]

Cart Menu

Command Key
Rename ⌘R
Change Grid ⌘G

Window Menu

Command Key
Minimize ⌘M