Workflow Tools

Broken Cues & Warnings

download video ↓

If a cue is missing one or more pieces of information it requires for playback, it will be flagged as a broken cue. Broken cues have a red X in the leftmost column of the cue list, and hovering your mouse over that red X shows a tooltip which gives a brief description of the problem.

Here are some common examples of problems:

  • A target has not been assigned to a cue which requires one.
  • A Fade cue has no activated parameters to fade.
  • A Group cue contains one or more broken cues within it.
  • An Audio cue has not been assigned to an audio patch.
  • There is a problem with the audio patch to which an audio cue has been assigned.
  • A Video cue has not been assigned to a surface.
  • There is a problem with the surface to which a Video cue has been assigned.
  • A MIDI, MIDI file, or Timecode cue has not been patched to a destination.
  • There is a problem with the destination to which a MIDI, MIDI file, or Timecode cue has been assigned.
  • The cue requires a license which is not installed or activated.

If your workspace contains any broken cues, a triangular indicator with an exclamation point appears on the right side of the footer (in addition to the red X beside each broken cue). Clicking the indicator opens the "Broken Cues and Warnings" panel, which contains a list of all the broken cues and a brief description of why they're broken. Clicking on a cue in that list will jump the selection in the cue list to that cue.

Broken Cues

A broken cue will behave like a disarmed cue when it comes to being played as part of a cue sequence. Its pre-wait, post-wait, and follow state will be respected wherever possible.

Cues which are flagged also appear in the broken cues and warnings panel. Flagged cues aren't necessarily broken, they're just listed for the purpose of having ready access to all flagged cues.

When a broken cue is fixed, its red X will disappear. When a workspace contains no broken cues and no flagged cues, the indicator in the footer with disappear as well.

The Cue Lists & Active Cues Sidebar

The Cue Lists & Active Cues sidebar, hidden by default, can be shown by choosing Cue Lists & Active Cues from the View menu, or by using the keyboard shortcut ⌘L. The sidebar shows four transport control buttons at the top, and two lists below them. You can click the headings of these two lists to switch between them, choose Toggle Between Cue Lists & Active Cues from the View menu, or use the keyboard shortcut ⇧⌘L.

Cue Lists sidebar (The inspector, shown in most screenshots in this documentation, is hidden here for clarity.)

The Buttons

  • Stop All. Stops all currently playing cues immediately, and unloads any loaded cues.
  • Reset All. Returns the playback position to the top of the currently active cue list, and resets any temporarily changed properties of cues to their default values.
  • Pause All. Pauses all currently playing cues.
  • Resume All. Resumes all currently paused cues.

Cue Lists

A new workspace will have one cue list named "Main Cue List." You can change this name as needed. To add a new cue list, click the button at the bottom of the sidebar labeled + Add New List. To delete a cue list (and all the cues in it!), select the cue list you want to delete and click the Delete button, which relabels itself to match the name of the selected list.

When a cue list is selected, the cues within that list are displayed in the main cue list view, and that cue list is considered to be the active cue list.

You can also click the disclosure triangle next to the name of a cue list to show or hide the cues within that list in the sidebar.

Active Cues

The Active Cues list shows all cues which are currently playing or paused.

Active Cues

Each active cue is displayed in its own row, with its own controls. The row shows the cue number and name, and the elapsed or remaining time in larger text. You can toggle between showing elapsed time and remaining time by clicking on the chevron in the list header.

On the left side of each row is a pause/resume button, on the right side is a panic button, and throughout the whole row is a progress bar, colored green when the cue is playing and yellow when the cue is paused, which gives a visual indication of the progress of the cue.

If you hover your mouse over an active cue, the leading edge of the progress bar will show a thick yellow line, which can be dragged left or right to scrub the cue backward or forward.

Load To Time

download video ↓

The Load to Time tool allows you to "fast forward" through the standing-by cue or cue sequence so that it is loaded to particular time, and will begin playing from that time when the GO button is pressed.

To access this feature, select Load to Time from the Tools menu, or use the keyboard shortcut ⌘T. Load to Time is one of the tools that occupies toolbar, and the menu or keyboard shortcut cycles through three states:

  1. When the Load to Time tool isn't displayed, the command will display it.
  2. When the Load to Time tool is displayed but the cursor isn't in its text box, the command will move it there.
  3. When the Load to Time tool is displayed and the cursor is in the text box, the command will close the Load to Time tool and move focus back to the cue list.

Load To Time

To use the Load to Time tool, type a number into the text field or drag the slider along the timeline to load the selected cue or cue sequence to your desired time.

If you type a negative value into the field, QLab will load to that amount of time back from the end of the cue or sequence, if possible.

Find

download video ↓

To search the workspace, select Find from the Edit menu in the toolbar, or use the keyboard shortcut is ⌘F. This feature searches cue names, cue numbers, the file names of audio and video cue targets, and any notes you've added (in the current cue list only).

Find is one of the tools that occupies toolbar, and the menu or keyboard shortcut cycles through three states:

  1. When the Find tool isn't displayed, the command will display it.
  2. When the Find tool is displayed but the cursor isn't in its text box, the command will move it there.
  3. When the find tool is displayed and the cursor is in the text box, the command will close the Find tool and move focus back to the cue list.

Find

The Audition Window

download video ↓

The Audition Window is a tool to listen to or watch cues privately without running them through your entire sound or video system. To access the audition window, select Audition Window from the Window menu or use the keyboard shortcut ⇧⌘A.

When the Audition Window is open, the GO button is replaced with a glowing "Audition" button to indicate that triggering new cues will audition them rather than playing them normally.

The Audition Window

The Audition Window has its own audio patch selector; any cues started when the audition window is open will play their audio to that patch instead of the patch selected in the cue.

The Audition Window audio patch is a convenient way to simulate a headphone or pre-fader level (PFL) bus: if you're using patch 1 for your audio interface, then you can assign patch 2 to your headphone jack or other local monitoring output, and hear the audio out of that alternate device by opening the Audition Window.

While the Audition Window is open, Video cues appear in the window instead of on their regularly assigned surface. If Video cues played to multiple surfaces are played at the same time, they are shown side by side in the Audition Window.

Any cues already playing when the Audition Window is opened will continue on their normal outputs. Only newly started cues are sent to the Audition Window and its audio patch.

You can scale your video output by any desired percentage using the scale control in the footer of the Audition Window, or click Fit to have QLab set the scale according to the current size of the window. It's best to click Fit while a Video cue is playing, otherwise QLab doesn't know what to measure against.

To exit the Audition Window, simply close it or type ⇧⌘A again, and your workspace will return to normal. Any cues which were started while the Audition Window was open will stop, and any cues which were started before the Audition Window was opened will remain unchanged.