The Light Dashboard

The Light Dashboard shows you the current, live levels of all lighting instruments in your workspace, and lets you manipulate them in real time. If you change a value in the Light Dashboard, the change will be sent immediately to the lighting hardware, and you will see that change live. Similarly, when you run a Light cue, you'll see the changes made by that cue reflected in the Light Dashboard as it happens.

You can open the Light Dashboard by choosing it from the Window menu or by using the keyboard shortcut ⇧⌘D.

Light Dashboard

Levels in the Dashboard can be modified a number of ways:

  • By typing commands into the Light Command Line;
  • By clicking and dragging on the sliders or tiles;
  • By double clicking in individual parameters' text fields and typing values;
  • Starting with QLab 4.4, by clicking and dragging on parameters' text fields.

Starting with QLab 4.2, decimal values are supported for parameters that use a percentage scale. You can only enter decimal values by typing or dragging on parameters' text fields. Dragged sliders or tiles will snap to whole numbers.

When dragging on parameters' text fields, the number of decimal places shown depends on whether the parameter is 8-bit or 16-bit; more decimal places are show for 16-bit parameters in order to give you as much precision as possible.

You can hold down the shift key while dragging to be even more precise.

When a level has been modified in the Dashboard, that parameter's control turns yellow.

The Light Command Line

This textual command line allows you to manipulate the Dashboard quickly and powerfully. You can learn more about how to use it in the Lighting Command Language section of this documentation.

Over Time

Typically, any commands you type into the command line will execute immediately when you hit enter. If you type a time into this field, however, the command will fade over that amount of time. This concept, called sneak on some other lighting consoles, allows you to make changes to the live state of your lights in a gentle, subtle way. The Over Time field resets itself to 0 after every use.

All or Used

When this drop-down menu is set to All, the Dashboard will display every instrument and light group defined in the workspace's patch.

When the drop-down is set to Used, the Dashboard will only display instruments and light groups which are currently recorded into cues plus any instruments or light groups which have been manually adjusted (i.e. any control that is drawn in yellow.)

Sliders or Tiles

The Dashboard offers two ways to look at your lighting:

Slider view shows one instrument or light group per line, sorted alphabetically, with a text field on the left side and a slider on the right. Values can be typed into the text field, or modified by clicking and dragging on the sliders. Multiple values can be adjusted at once by shift-clicking on two or more sliders and then dragging.

Any row containing a value that has been manually adjusted since a Light cue was run will display a yellow background. Rows which represent groups show yellow marks to indicate different levels of individual instruments within the group.

Mixed levels

Instruments and light groups that have more than one parameter will have a disclosure triangle on the left edge of the Light Dashboard. When the triangle is pointing to the right, only the default parameter of the instrument or light group (typically the intensity parameter) will be shown. If you click the triangle, the slider will "unfold" to show all parameters.

Parameters

Light groups contain all the parameters for every instrument they contain.

Tile view shows each parameter of every instrument or light group as a tile with the level of the parameter above in larger text, and the name of the instrument and parameter below in smaller text. Tiles are divided into light groups, "simple" lights, which are all single-parameter instruments, and "fancy" lights, which are all multi-parameter instruments. The brightness of the outline of each level display reflects the current value of that parameter.

Tiles

Any tile containing a value that has been manually adjusted since a Light cue was run will display a yellow background.

Latest Light Cue

Latest Light Cue. Unlike many other lighting consoles, QLab is not restricted by the concept of being "in" a cue, since the results of more than one cue can be reflected on stage at once. Rather, QLab tracks cues as they are triggered, and lists the most recently run Light cue here.

Revert Changes & Clear All

Clicking Revert Changes ⌘R will restore all parameters that you've changed in the Light Dashboard to the levels that they were last set to. This restore happens over the workspace's panic duration.

To revert only individual changes, rather than everything you've changed, the Dashboard supports undo (and redo).

Clicking Clear All will clear any modifications made in the Dashboard and set all parameters of all lights to their home value. Please be aware that this generally causes a blackout. This button is the QLab equivalent of what many other consoles refer to as "Go To Cue out."

Recording and Updating Cues

In the lower right corner of the Dashboard are four buttons for creating and updating cues. Cues created using these buttons will appear in the current cue list or cart, directly after the selected cue. If no cue is selected, new cues will appear at the end of the current cue list or cart.

Record All

The Record All... button displays a pop-up menu with three options, each of which may only be available depending upon the situation:

Latest Cue. Record all current light levels into the latest Light cue, overwriting any levels already in that cue. If no Light cues have been run, and no cue is displayed to the left as the latest Light cue, then this option is not available.

Selected Cue(s). Record all current light levels into the currently selected Light cue or cues, overwriting any levels already in those cues. If there are no currently selected Light cues, then this option is not available.

New Cue. Record all current light levels into a new Light cue. In QLab, in the context of lighting, the word record is used to mean "capture the current level of all parameters of all instruments in the workspace." What this means is that any parameters that do not have an explicit level in the Light Dashboard (i.e. those parameters which haven't been touched since the workspace was opened) will be recorded at their home value (typically 0.) In this way, cues created or modified using Record All... function as blocking cues.

Update

The Update... button becomes enabled whenever the Dashboard contains modified (yellow) values, and it displays a pop-up menu with three options, each of which may only be available depending upon the situation:

Latest Cue (⌘U). Copy all modified light levels into the latest Light cue. If the modified levels belong to lights or groups that are already in the latest cue, QLab will overwrite those levels. If not, QLab will add them and leave everything else alone. If no Light cues have been run, and no cue is displayed to the left as the latest Light cue, then this option is not available.

Selected Cue (⇧⌘U). Copy all modified light levels into the currently selected Light cue or cues. If the modified levels belong to lights or groups that are already in the selected cue or cues, QLab will overwrite those levels. If not, QLab will add them and leave everything else alone. If there are no currently selected Light cues, then this option is not available.

Originating Cue (⌥⌘U). Copy all modified light levels into the cue or cues which originated their current levels. This concept is most similar to "record track" and is explained in more detail below.

New Cue with All

This button serves as a shortcut for Record All > New Cue. You can also use the keyboard shortcut ⇧⌘N.

New Cue with Changes

This button records only changed levels into a new Light cue. For example, consider this screen shot:

New With Changes

Here, a Light cue has been run which raised instrument 4 to 24 and instrument src4 to 69. Then, instrument 2 has been manually set to 36 and instrument 3 has been manually set to 50

If you click New Cue with Changes when the Dashboard looks like that, QLab would create a new cue containing 2 = 36 and 3 = 50. Instruments 1, 4, src4, and viper are not recorded into the cue because their levels have not been modified in the Dashboard.

When you run this new cue, only 2 and 3 will change, and the other lights will be left alone at whatever levels they're already set to. In this way, cues created using New Cue with Changes function as tracking cues.

Originating Cues Explained

Since not every cue needs to provide a value for every instrument, it is possible that, after running several cues, the Dashboard reflects the handiwork of more than one cue. Update Originating Cue(s) will update the value of each instrument in the cue that originated the level for that instrument. This is complicated, so we'll walk through that step by step. Consider a show with six instruments, and five cues:

Cue 1 2 3 4 5 6
1 100 100 100 100 100 100
2 15 15 15
3 80
4 25 25
5 50

After running all five cues, in order, the live state of the lights in this show are:

Cue 1 2 3 4 5 6
Live: 15 80 50 25 25 100

The levels for each instrument originate in different cues:

Cue 1 2 3 4 5 6
1 100 100 100 100 100 100
2 15 15 15
3 80
4 25 25
5 50

If you ran those five cues, and then adjusted instruments 3, 5, and 6 to new levels, let's say all to 75, the button would read Update 3 Originating Cues because those three instruments' levels originated in three different cues. If you then clicked the button, those originating cues would all be updated:

Cue 1 2 3 4 5 6
1 100 100 100 100 100 75
2 15 15 15
3 80
4 25 75
5 75

The DMX Status Window

The DMX Status Window, which you can find under the Window menu, is a diagnostic and troubleshooting tool that's not part of the Light Dashboard, but is related. The DMX Status Window shows the current value of one universe of DMX at a time, and lets you manually set the level of individual addresses. You cannot record changes you make in this window; it's intended only to help you solve patching errors, discover whether a misbehaving fixture is correctly addressed, etc.

The Tools Menu

When the Light Dashboard is the frontmost window, the contents of the Tools menu is re-populated with relevant menu items:

New Cue with Changes (⌘N)
New Cue with All (⇧⌘N)
Update Latest Cue (⌘U)
Update Selected Cues (⇧⌘U)
Update Originating Cues (⌥⌘U)
Record All to Latest Cue
Record All to Selected Cues
Clear All
Revert Changes (⌘R)
Park Selected Lights
Unpark Selected Lights

Parking

Parking an instrument freezes its current state until it is unparked. While parked, neither cues nor the Light Dashboard can alter the actual live state of the parameter, and the parked value cannot be recorded into cues. This can be helpful for things like keeping house lights at a glow during focus, or preventing a strobe light or fog machine from turning on while working on cues.

To park an instrument, set the Light Dashboard to Slider view, select the instrument's slider, and choose Park Selected Lights from the Tools menu. If the instrument has more that one parameter, you can select the top-level slider to park the whole instrument, or you can select one or more parameters' sliders to park only those parameters.

You can park multiple instruments, groups, or parameters by command-clicking on multiple sliders.

When a parameter is parked, it is drawn with a diagonal striping overlay much like a disarmed cue.

Parameters can still be edited while parked, but the actual DMX output from QLab will remain locked to whatever value was set when the parameter was parked. The parked value will be shown on the fader track using a yellow light mark.

Parking

In this screen shot, two parameters of the Viper have been parked: the shutter parameter is parked at 30, and the cto parameter is parked at 0. The cto parameter has subsequently been set to 25, and the light mark shows that the current live value of the cto parameter remains at 0. All other parameters of the instrument remain unparked and can be used as normal.

To unpark an instrument or parameter, select it in the Light Dashboard and choose Unpark Selected Lights from the Tools menu.

When an instrument or parameter is unparked, QLab immediately updates the live value being sent to that instrument or parameter. This could cause surprising behavior if, for example, you park a group of strobe lights at 0, then run a cue which brings them to full, and then unpark them. Because of this, QLab displays confirmation dialogue boxes for both parking and unparking.